Runcloud iOS app update today.. 2FA still broken

As the title says… nice integration of Discourse… but I still keep getting asked for a 2FA code on every login despite using FaceID. Just me?

1 Like

Hey @brad. Really sorry for the inconvenience here.

According to our testing/release logs, this passed QA and was released & so should be working (+ yours is the first report that it currently isn’t).

Would you be able to try uninstalling and reinstalling the app to see if that makes a difference?

Still the same result.

Still can’t dismiss the keyboard after adding 2FA code

1 Like

Do you also keep getting asked for 2FA on each login?

I have 2FA enabled, but on mobile I can’t get passed the keyboard as there is no ‘done’ button, so I can’t login at all

You can see the send button initially but when I swap apps to Authenticator to get the code and swap back to RC, the send/done button is inaccessible and you are stuck

That doesn’t happen to me… I usually paste the 2FA code in and still see the “send” button.

What phone type do you use?

iPhone 12pro max at the moment

Same here, have also a ticket about this. They say that its the correct behaviour… Well. Its not!
Even told them that back/crypto apps don’t even do it this way…

Using iPhone 14 Pro

I have an iPhone XR - basically i cant use the RC app as I cant dismiss the keyboard

@alex any updates here?

Hey @brad & @kay – sorry for the delay, this request wasn’t picked up until today as I was at WCEU. We had started looking into it earlier today & should have an update this week.

Thanks for your patience. :pray:

Awesome! I have already a ticket open for this for over 1.5 Month.
Hopefully this gets fixed now!

Just updated the app… Still the same issue… When will this be fixed?

Working for me now In terms of the 2FA box layout and I can see and use the Send button.

But I can’t comment in the Community section as it errors

I can also replicate that… unable to reply in the community. I get the same error message.

Also, I still get asked for a 2FA code every time I login to the app… despite having FaceID enabled. Perhaps it’s a IPv6 thing? Everyone else can login using FaceID and not get asked for their 2FA each time?
It’s really annoying as notifications work via the app yet I have to login with a 2FA code to even open them.

Edit: Just to add… each time I login I have to provide a 2FA code… then I get the security email to say a new web browser just logged into my account (and lists my IP address of course).

I have FaceID enabled and also have to enter 2FA code each time

Kind of defeats the purpose of using FaceID?
The frustrating thing is… even though we need to enter a 2FA code again, the app is actually logged in and receiving notifications.

Runcloud support have confirmed with me they are aware of these 2 issues.